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welcome to the ultimatte labs!   
watch for important tips from

me (or my lab rat) throughout
this manual!  

first tip: have fun!
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Ultimatte is blue screen or green screen image compositing and matting software with

the unique ability to maintain all detail in the foreground scene. The matte necessary

to produce seamless composited images is generated automatically using the same

patented Ultimatte algorithms as used in the television and motion picture industries.

M I N I M U M S P E C I F I C A T I O N S &
R E Q U I R E M E N T S

•Adobe After Effects, version 3.0
•24-bit Color Monitor.
•Macintosh OS 7.5  

or 
•Windows NT 4.0
•Windows 95

I N S T A L L A T I O N

Macintosh:
Install plug-ins by dragging all three
effects into the After Effects plug-in folder.

Win95/NT:
Install plug-ins by copying all three 
effects into the After Effects effects 
folder. 

S E C U R I T Y K E Y

Macintosh;
Ultimatte is protected by an EVE
security key from Rainbow
Technologies. The key must be con-
nected to an ADB (Apple Desktop Bus)
port while the software is running. The
ADB port is the port to which the 
keyboard and the mouse are attached.
The security key can be attached
directly to the port on the computer, to
the cable between the computer and
the keyboard, or between the keyboard
and the mouse.

Win95/NT :
Ultimatte is protected by a Sentinel security
key from Rainbow Technologies. The key
must be connected to a parallel port
(preferably the LPT1) while the software is
running.

To install the security key drivers, please
follow the Read Me file on the software
disk.

T H E U L T I M A T T E P L U G - I N
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G e t t i n g  S t a r t e d

S C R E E N C O R R E C T I O N

Screen Correction compensates for
anomalies in the blue (green) screen;
uneven lighting, smudges, seams, or
blue set pieces. Using an exact copy
of the problematic blue screen ele-
ment with the subject matter removed,
this effect will rid the foreground of
these unwanted anomalies, giving the
impression of being shot against a
perfect blue field.

G R A I N K I L L E R

Grain Killer reduces noise in the
screen area of the foreground often
created by film grain, video noise, or
compression.

U L T I M A T T E

Ultimatte seamlessly composites 
foreground blue screen elements into
a background scene retaining all
detail. If the camera can see it,
Ultimatte can composite it.

To obtain the best results, use the
plug-ins in the following order:
Screen Correction, Grain Killer,
Ultimatte.

All three plug-ins appear in a similar
effects dialog box. The following
pages will explain common features
within Screen Correction, Grain Killer
and the Ultimatte effects.

The Ultimatte plug-in package is designed to create flawless composites. This package

consists of Screen Correction, Grain Killer, and Ultimatte.

T H E F E A T U R E S &  T H E I N T E R F A C E
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C R E A T I N G T H E P R O J E C T &  T H E D I A L O G B O X

L O A D  I M A G E S  I N T O  P R O J E C T.

Load the Foreground, Screen Correction, and Background Footage into the
project. To achieve the highest quality, be sure to import clips with no or 
little compression. 

This is an example of a typical Ultimatte Comp.  Drag and drop the Background,
Screen Correction and the Foreground onto the Comp 1 icon within the project
window. This will assure that your clips are perfectly aligned. Remember to keep
the Foreground clip above the Background clip in the time layout window. 

This is an example of a typical Ultimatte Effects panel within After Effects. All
Ultimatte effects are located in Effects>Ultimatte. 
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G e t t i n g  S t a r t e d

T O O L S

The following tools are commonly used during the Ultimatte process.

Effects Switch

Twirl Down
Arrow

View Pull
Down Menu

Eyedropper

Sampled
Screen Color

Slider

Number
Field
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Effects Switch: This box will allow the effect to
easily be turned on or off.

Eyedropper: The eyedropper tool is used by
placing the tip over the desired area and 
clicking the mouse to collect data. 

Eyeball: This icon allows a layer to remain in
the time layout without being visible. “Closing”
the eyeball for the screen correction layer will
allow the clip to be used as a reference layer.

Info Palette: This palette contains RGB values
and will be helpful when using Grain Killer. The
Info palette is located in Windows>Palettes>Info.

Number Field: Click once on any underlined
number field to enter a numeric setting. In the
dialog box, type in the desired value, click OK.

Slider: This option allows you to click and drag
on the triangular handle to change settings.
Holding the Option (Mac) / Alt (Win95/NT) key
while moving this control will update the Comp
window for every value. Remember that After
Effects does not  allow for real time rendering,
therefore allow time for settings to change. .

Twirl Down Arrow: Click once on this icon to
expose or collapse controls.

Zoom: Located in the tools palette, the zoom
tool will allow a closer view of the image. Hold
the Option (Mac) or the Alt (Win95/NT) key
while clicking to "zoom out" of the frame. 
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G e t t i n g  S t a r t e d

Background
The image that will replace the 
backing color of the foreground in the
final composite. Also noted as BG.

Backing Color
The blue or green screen area.

Composite
The foreground image (with the 
backing area and flare removed) 
combined with the background clip.

Flare
Contamination of the blue (green)
screen on to the foreground subject.
Also referred to as spill.

Foreground
The subject matter against the 
backing color. Also noted as FG.

Garbage Matte
A way of eliminating a portion of an
image. This can be done in several
methods.  Also referred to as a
track matte.

Grain Killer
Grain Killer reduces noise in the
screen area of the foreground often
created by film grain, video noise, or
compression.

Matte
A black, gray and white image that is
used to determine the percentage of
foreground and background values.
Also referred to as alpha channel.

Print-thru
When areas of the background are
visible through the foreground subject
where they should not be seen, or
when the foreground is not opaque in
areas that should be opaque. 

Processed Foreground
The foreground image with the 
backing area suppressed to black and
all flare removed. 

Screen Correction 
Screen Correction compensates for
anomalies in the blue (green) screen;
uneven lighting, smudges, seams, or
blue set pieces. Using an exact copy
of the problematic blue screen ele-
ment with the subject matter removed,
this effect will rid the foreground of
these unwanted anomalies, giving the
impression of being shot against a
perfect blue field.

Screen Correction Scene
An identical copy of the original 
foreground with no props or talent, no
camera changes, and no lighting
changes.

Veiling
A colorized haze over the background.

Ultimatte
Ultimatte seamlessly composites 
foreground blue screen elements into
a background scene retaining all
detail. If the camera can see it,
Ultimatte can composite it.

W O R D S T O K N O W



professor warhol tip:  
not sure if you should be
using green or blue? check
out the overview manual for
this and other important 

information! 
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F O R B E S T R E S U L T S U S E S C R E E N C O R R E C T I O N ,  T H E N  G R A I N

K I L L E R F O L L O W E D B Y U L T I M A T T E .

Screen Correction compensates for anomalies in the backing area such as uneven

lighting, smudges, seams, variations in the backing color, blue (green) set pieces, and

unwanted shadows cast by set pieces. By using an exact copy of the problematic blue

(green) screen element with the foreground subject matter omitted as a reference, the

patented Screen Correction algorithms will automatically correct the foreground so that

the levels of the blue (green) screen are the same throughout each frame. Screen

Correction differentiates between foreground elements and backing flaws, thereby

allowing the Ultimatte algorithms to retain all foreground detail without compromise

because of a poorly shot foreground element. For further explanation on Screen

Correction, see the Screen Correction section in the Ultimatte Overview Manual. 

lab rat tip: 
if you didnÕt capture a frame
of the blue screen without the

talent, create one in a 
program such as photoshop!

U N E V E N L I G H T I N G ,  S M U D G E S &  S E T P I E C E S
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I N  T H E  T I M E  L AY O U T  W I N D O W,  B E  S U R E  T O  A L I G N  T H E
S C R E E N  C O R R E C T I O N  L AY E R  P E R F E C T LY   W I T H  T H E
I N / O U T  P O S I T I O N  O F   T H E  F O R E G R O U N D  L AY E R  .

S c r e e n  C o r r e c t i o n

Switch the view (eyeball) to off on the Screen
Correction layer.

Select the foreground clip in the Time Layout Window.

Change “Switches” to “Transfer Controls” in the
Time Layout. 

Change the Foreground
transfer mode by holding
down Option(Mac) or
Alt(Win) and dragging from
“Normal” to “Luminescent
Premul”. 

With the Foreground clip still selected, apply
Effects>Ultimatte>Screen Correction
from the menu bar. 

Normal
Dissolve
Dancing Dissolve
Add
Multiply
Screen
Overlay
Soft Light
Hard Light
Darken
Lighten
Difference
Hue
Saturation
Color
Luminosity

Stencil Alpha
Stencil Luma
Silhouette Alpha
Silhouette Luma

Luminescent Premul
Alpha Add
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S A M P L E T H E B A C K I N G C O L O R

In the effects dialog box, use the eyedropper tool to sample the backing color of the
FG (foreground) image that appears in the viewing area. Be careful to select an area
of backing unobscured by any FG detail (smoke, hair, reflections in glass, or shadow
areas).

Set the Correction Layer pull down menu to the Screen
Correction layer.

Set the View pull down menu to Corrected Foreground.
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S c r e e n  C o r r e c t i o n

O V E R C O R R E C T I N G

The Matte Density and Black Gloss controls are used to isolate the foreground image
from the backing. The control names are the same as in Ultimatte, but they are used
differently. When using Screen Correction, the matte should have perfect density or be
slightly over dense, but never under dense. If an object that should have an opaque
matte has a semi-transparent matte, Screen Correction will try to partially correct that
object, thereby making it closer to the actual backing color. This will cause more print-
thru problems when the Ultimatte plug-in is used.

If subject matter, a blue tie, is being corrected, the following controls may be adjusted
using these guidelines.

Switch View pull-down menu to matte: 

• Matte Density: Use this control to stop print-thru in bright foreground objects. 

• Black Gloss: Use this control to stop print-thru in black glossy or dark foreground 
objects.

SUMMARY

•Switch the eyeball off for the Screen Correction layer
•In the Time Layout Window, Select the Foreground layer 
•Holding the Option(Mac) or Alt(Win) key, Change Transfer 
Control  to Luminescent Premul for the Foreground
•Effects>Ultimatte>Screen Correction 
•Sample Backing Color of the foreground layer
•In the Effects Box, set the Correction layer pull-down 
menu to the Screen Correction layer
•Set the View pull-down menu to Corrected Foreground 



professor warhol tip:  
the next steps should be
grain killer and then 

ultimatte!

Page 13





G
R
A
IN

 
K
IL
L
E
R

Page 15

B E S U R E T O U S E S C R E E N C O R R E C T I O N B E F O R E T H I S S T E P.

Grain Killer is a filtering process which reduces film grain or video noise in the blue

(green) screen area only. One would expect to find grain or noise in both the 

background and foreground scene. When compositing these scenes together, the grain

or noise that is in the blue (green) screen area, will be composited as well, thereby

making the background even noisier than it was originally. This becomes especially

problematic in multi-layered composites where the addition of noise as each layer is

added could make the shot unusable. If a traditional process which does not distin-

guish subject matter from the blue (green) screen area before filtering were applied,

then an overall softening of the image would occur. Grain Killer will soften shadows.

For further explanation on Grain Killer, see the Grain Killer section in the Ultimatte

Overview Manual. 

G R A I N Y &  N O I S Y B A C K I N G A R E A
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G r a i n  K i l l e r

In the effects dialog box, use the eyedropper tool to sample the backing color of the FG
(foreground) image that appears in the viewing area. Be careful to select an area of 
backing unobscured by any FG detail (smoke, hair, reflections in glass, or shadow areas). 

In the Effects dialog
box, switch the View
pull down menu to Filter
Area.

Be sure that the After Effects
Info palette is visible.

Next, define the filter area in RGB channels.  This process will define areas of the back-
ing to be filtered. The white areas represent filter areas (screen ), while the black and col-
ored sections represent areas not to filter (subject and transitions areas). The ideal set-
tings  should be such that the film grain or video noise in the backing color become part
of the filtered area (white).
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With the cursor, identify the RGB value of the black pixels representing noise in the screen
area only. While moving the cursor over these black pixels, take note of the RGB values in
the Info palette. For example, when the cursor touches a black pixel of the screen area, the
RGB values in the Info palette displays “7,15,3 .” A different black pixel might have RGB 
values of “18, 9, 2.” And a third pixel may have RGB values of “14, 8, 0.” Enter the highest
value in the respective offset control on the Grain Killer effects panel. In this example, set
the Red Offset to “18,” the Green Offset to “15,” and the Blue Offset to “3.”

B E F O R E A F T E R

Repeat this process until the screen area is white, ADDING the largest value to the appro-
priate offset control. Therefore if the next set of RGB values is “5, 2, 1,” the new Red Offset
value should be “23.” (Previous setting 18 + 5=23) Follow this procedure in the G and B
channels.

Master Offset will increase the Red, Green and Blue offset simultaneously and is additive to
the individual offset controls.  For example, if the RGB values  “24, 32, and 11”  were
observed, adjust the Master Offset to the lowest of the RGB values:  “11.”  This will quickly
change the range of the offsets. 

Switch between the filtered foreground and the foreground to determine if 
filtering is occurring in the subject matter.

Set the View pull down menu to Filtered Foreground. 
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G r a i n  K i l l e r

G R A I N Y O R N O I S Y B A C K I N G

The Matte Density and Black Gloss controls in this menu are used to isolate the fore-
ground image from the backing. The control names are the same as in Ultimatte, but they
are used differently. When using Grain Killer the matte channel controls the amount of fil-
tering that will occur in transparent areas and edges. If the matte is under dense, then
too much filtering will occur in the semi-transparent areas, thereby giving the impression
of a softer image or a loss of detail. Therefore, attempt to create either a perfectly dense
or over dense matte.

Set these controls using the following guidelines.

• Matte Density: Use this control to stop filtering in bright foreground objects. 

• Black Gloss: Use this control to stop filtering in black glossy or dark foreground objects. 

SUMMARY

•In the Time Layout Window, Select the Foreground Layer
•Hold down the Option(Mac) or Alt(Win) key and Change Transfer   

Control to Luminescent Premul for the Foreground layer
•Effects>Ultimatte>Grain Killer 
•Sample Backing Color
•In the effects dialog box, set the Offset Controls
•Set the View pull-down menu to Filtered Foreground 



professor warhol tip:
if your image still appears

grainy, using additional grain
killer passes will help.  simply

place the new grain killer
effect below the previous 

grain killer effect. 
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C O M P O S I T I N G

B E S U R E T O U S E S C R E E N C O R R E C T I O N A N D G R A I N K I L L E R

B E F O R E T H I S S T E P .

Ultimatte has the unique ability to composite anything the camera can see, including

but not limited to, smoke, shadows, glass, reflections, fine detail, and motion blur. 

Select the foreground clip in the Comp Time Layout Window

If you haven’t already done so, Change
“Switches” to “Transfer Controls” in the Time
Layout. 

Change the Foreground
transfer mode by holding
down Option(Mac) key or
Alt(Win) and dragging from
“Normal” to “Luminescent
Premul”. 

With the Foreground clip still selected, apply
Effects>Ultimatte>Ultimatte from the menu bar. 

Normal
Dissolve
Dancing Dissolve
Add
Multiply
Screen
Overlay
Soft Light
Hard Light
Darken
Lighten
Difference
Hue
Saturation
Color
Luminosity

Stencil Alpha
Stencil Luma
Silhouette Alpha
Silhouette Luma

Luminescent Premul
Alpha Add
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U l t i m a t t e
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In the effects dialog box, use the eyedropper tool to sample the backing color of the
FG (foreground) image that appears in the viewing area. Be careful to select an area
of backing unobscured by any FG detail (smoke, hair, reflections in glass or shadow
areas).

To determine which settings need to be adjusted, you may need to switch between
“Matte” and “Composite” in the View pull down menu. 
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M A T T E C O N T R O L S

These controls are used to adjust the density or opacity of the foreground objects. The
density of a foreground object is determined by its matte (alpha) value.  A completely
opaque object's matte will be white, a completely transparent object's matte will be
black, and a partially transparent object's matte will be gray.  Reducing the density of
the foreground object's matte can reduce dark matte lines from showing in the com-
posite. Set these controls while viewing both the matte and composite.

P R I N T T H R U ,  D A R K &  G L O W I N G E D G E S

Adjust the first six matte controls following these guidelines.

•Matte Density: Use this control to stop print-thru in bright foreground objects.  
Warning: Advancing this control too far can cause hard, dark edges around 
foreground subjects.

•Black Gloss: Use this control to stop print-thru in black glossy or dark foreground
objects. Warning: Advancing this control too far can cause hard, dark edges around
foreground subjects.
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T H E F O L L O W I N G A D D I T I O N A L A D J U S T M E N T S N E E D T O B E M A D E

B A S E D O N T H E F O R E G R O U N D S U B J E C T M A T T E R A N D T H E S C R E E N

C O L O R .

•Black Gloss 2: Use this control to stop print-thru on foreground objects that have an

excessive amount of spill from the backing. This control adjusts the foreground prior to

generating the matte, thereby giving the appearance of being both a matte control and

a flare control. View both the matte and the composite when adjusting  this control.

Warning: Advancing this control too far can alter the color of the foreground objects.

• Red Density: (not available for red backing): Use this control to reduce dark edges

from reddish objects (flesh tones). Warning: Reducing this control too much can cause

print-thru in reddish foreground objects.

•Green Density: (not available for green backing): Use this control to reduce dark

edges from greenish objects (plants). Warning: Reducing this control too much can

cause print-thru in greenish foreground objects.

•Blue Density: (not available for blue back-

ing): Use this control to reduce dark edges

from bluish objects. Warning: Reducing this

control too much can cause print-thru in

bluish foreground objects.
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H A R D E D G E S, G L O W I N G E D G E S &  S C R E E N I M P E R F E C T I O N S

The following matte controls are used to adjust the white and gray areas of the matte
channel. This will dramatically affect the nature of foreground objects' edges, the
opacity of transparent objects, and the noise in the background image.  Use these
controls sparingly as they WILL result in the loss of foreground detail. The proper
technique for dealing with imperfections in the screen is the use of Screen Correction
and Grain Killer.

A D J U S T T H E L A S T F O U R M A T T E C O N T R O L S F O L L O W I N G T H E S E

G U I D E L I N E S .  

•Clean Up: Use this control to reduce imperfections or small amounts of noise in 
the backing. Warning: Advancing this control too far will result in a "cut and paste"
look. Background noise (as well as some foreground detail) will be reduced . A better
method for dealing with imperfections is the use of Screen Correction and Grain Killer.

•Clean Up Balance: Used only when the Clean Up control has been adjusted, this
control determines how much influence the Clean Up control will have on the fore-
ground and background images. View both the matte and the composite when adjust-
ing  this control. If using the Clean Up control caused glowing or dark edges, Clean
Up Balance can be used to reduce this problem.

•BG Level Balance: Use this control to override the automatic setting of the 
Background level as turned on by the matte, based on where the backing color 
was selected. View both the matte and the composite when adjusting  this control.
Decreasing this control can enhance the appearance of fine foreground detail, but will
darken the background image, and increase "visual noise". Increasing the control can
remove "visual noise" and brighten dark edges. Warning: Advancing this control too
far can cause foreground objects' edges to glow.

•Shadow Noise: Use this control to reduce noise in
shadows and glare areas. View both the matte and the
composite when adjusting  this control. Warning:
Decreasing the control too much will reduce fine detail. 
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E X C E S S I V E S P I L L &  M I S C O L O R E D S U B J E C T M A T T E R

The Ultimatte algorithms will automatically suppress flare caused from the backing
onto foreground subject matter. The flare controls are used to suppress excessive
spill. Set the View pull down menu to Composite when adjusting these controls.

•White Balance: Use this control to remove excessive spill on bright foreground
objects.

•Gray Balance: Use this control to remove excessive spill on midrange foreground
objects.

•Black Balance: Use this control to remove excessive spill on dark  foreground
objects.

•Gate 1/3: ("Gate one three") Use this control to reproduce blues, greens, 
or cyans. 

For Blue Screen: At 100%, greens will be reproduced.  At 50%, 
blues will become cyan. At 0%, blues and cyans turn green.

For Green Screen: At 100%, blues will be reproduced.  At 50%, 
greens will become cyan. At 0%, greens and cyans turn blue.

•Gate 2: Use this control to reproduce the following colors:

For Blue Screen: used to reproduce 
pinks, purples, and magentas 
turn red. Warning: Since skin 
tones are pinkish, advancing 
this control too far may add blue to the 
skin tones.

For Green Screen: used to reproduce 
yellows and orangesturn red. 
Warning: Since skin tones are 
pinkish, advancing this control 
too far may add green to the 
skin tones.
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M I S C O L O R E D S C R E E N A R E A &  M I S C O L O R E D E D G E S

These controls are used to override the automatic suppression of the backing color.
The Ultimatte process uses the selected backing color to suppress the backing to
black. An indication that the automatic settings did not suppress enough backing is
"veiling" or a colorized haze over the background. An indication that the automatic
settings suppressed too much backing is darkened or miscolored foreground edges
and transparencies. View the composite when adjusting this control. In most cases
these controls will be left at their default settings.

•Red: This control overrides the automatic suppression of the red channel.  
Increasing this control will increase the amount of red veiling (residue) left in the 
backing area. Decreasing this control will cause foreground edges and 
transparencies to turn cyan.

•Green: This control overrides the automatic suppression of the green channel.  
Increasing this control will increase the amount of green veiling (residue) left in the 
backing area. Decreasing this control will cause foreground edges and 
transparencies to turn magenta.

•Blue: This control overrides the automatic suppression of the blue channel.
Increasing this control will increase the amount of blue veiling (residue) left in the 
backing area. Decreasing this control will cause foreground edges and 
transparencies to turn yellow.
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•In the Time Layout Window, Select the Foreground Layer 
•Hold down the Option(Mac) Alt(Win) key and Change 

Transfer Control to Luminescent Premul for the 
Foreground layer

•Effects>Ultimatte>Ultimatte 
•Sample Backing Color
•In the effects dialog box, set the Matte, Flare, and Screen 

Controls, if necessary
•Set the View pull-down menu to Composite 

SUMMARY

lab rat tip: 
darkened edges? check that
the transfer mode of the fg
is set to luminescent premul.
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A D D I T I O N A L A F T E R E F F E C T S F E A T U R E S

As a plug-in, all of the After Effects features are available when using Ultimatte (i.e.
keyframes)

C O L O R C O R R E C T I O N

Color Correction should always occur after the matte has been generated by
Ultimatte. After Effects has quite an extensive set of color controls, located under
Effect >Image Control. 

G A R B A G E M A T T E

Several methods can be applied to create garbage mattes. The most direct method is
to use Mask Handles or Mask Vertices.

•Double click on the foreground clip in the Time Layout window to expose the
Foreground layer. Switch the pull down menu (currently displaying “none”) to “Mask
Handles.” 

•Grab one of the 8 handles on the outside edge of the image. Drag handle into the
frame. View Composition window to see the change. 

•Using “Mask Vertices” will produce a similar effect. Use the pen tool from the Tool
box to create points and curves to outline the undesired portion of the frame. 

•Advancing the clip and changing the mask position will allow a track matte to be cre-
ated.

L U M I N E S C E N T P R E M U L

Luminescent Premul is the transfer mode that Ultimatte uses to combine images
using an additive mix. Try using other transfer modes to create various special effects. 

For more information regarding any of these tips, consult Adobe’s After Effects
Manual. 
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N O T E S

lab rat tip: 
use this page to

take notes.



Professor Warhol and the Lab Rat are copyright of Keith Robinson.

All product names are registered trademarks
of their respective companies.

©Copyright 1990, 1991, 1992, 1993, 1994,
1995, 1996, 1997. All Rights Reserved.
Confidential and Proprietary. Ultimatte
Corporation. 20554 Plummer Street,
Chatsworth, CA 91311 
U.S.A. 

U.S. Patent Numbers: 
4,344,085; 4,625,231; 5,032,901; 5,202,762;
5,343,252; 5,424,781; 5,515,109; 5,557,339;
with corresponding foreign patents 
and patents pending.
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